I have a Asus K501UQ with an Intel which worked fine on my Windows partition. I've put on Elementary OS (Loki) but the card is disabled and I'm not able to enable it.

rfkill list all


0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

So perhaps it's because the interface is hard blocked but I'm not sure why there are two Wireless LAN interfaces listed here.

lshw -class network


       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 10
       serial: 34:97:f6:15:c5:38
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-3_0.0.1 04/23/13 ip= latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:127 ioport:d000(size=256) memory:df204000-df204fff memory:df200000-df203fff
  *-network DISABLED
       description: Wireless interface
       product: Wireless 7265
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 59
       serial: 48:45:20:c5:c9:1b
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-59-generic firmware=19.324151.0 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:132 memory:df100000-df101fff

If I perform:

sudo sudo ifconfig wlp3s0 up

I get the error:

SIOCSIFFLAGS: Operation not possible due to RF-kill

I'm assuming this is because phy0 is hard blocked. As far as I'm aware there's no physical switch on my laptop and it works if I boot into Windows. I've hit the limit of my knowledge, any help would be greatly appreciated.

  • Can you edit your question and add the output of "lsmod | grep asus"?
    – bitseater
    Commented Jan 21, 2017 at 23:15
  • Pleased to say this issue wasn't present on Juno.
    – samblake
    Commented Jan 12, 2019 at 11:58

7 Answers 7


It is likely you need to use the wapf parameter in asus-nb-wmi. The kernel source code tells us this about wapf

 * WAPF defines the behavior of the Fn+Fx wlan key
 * The significance of values is yet to be found, but
 * most of the time:
 * Bit | Bluetooth | WLAN
 *  0  | Hardware  | Hardware
 *  1  | Hardware  | Software
 *  4  | Software  | Software

Using wapf=4 seems to work for most computers with hard block issues and we can apply this with

echo "options asus-nb-wmi wapf=4" | sudo tee /etc/modprobe.d/asus-nb-wmi.conf

Reboot and see if wireless works

  • what is asus-nb-wmi? what would be the equivalent for other laptops? how to get that specification? I am looking for a more general solution than just for Asus
    – user170
    Commented Apr 18, 2018 at 12:50

Try "nmcli radio wifi on". It works for me.

  • Thanks, this seems to be still an issue on Juno....
    – phrogg
    Commented Aug 10, 2019 at 15:44
  • the only way to turn on my wifi. when I turn it off from GUI, It won't turn on again from there. Commented Aug 18, 2020 at 3:57

I have this problem too when I disable physically my WiFi connection (Hardware blockage) , or just simply by turning WiFi off by clicking on the toggle in the WiFi list connection ( Sfteware blockage)

In both cases, I was using this command to solve the problem

sudo rfkill unblock 0

but I am not sure if it is going to help you since it sounds that your WiFi card is unblocked.


Used my iPhone to get a temporary Internet connection, and found this site: http://www.edimax.com/edimax/download/download/data/edimax/global/download/for_home/wireless_adapters/wireless_adapters_ac1750_dual-band/ew-7833uac

Used the Linux drivers for my ASUS 1900 AC68 USB device and worked on the first try. Before I updated the driver, I performed all of the OS updates through my iPhone, just in case that makes a difference.

  • you mean you installed the driver for a connection to an Edimax wifi rooter? what's the relation with the question above?
    – user170
    Commented Apr 18, 2018 at 12:53

This worked for me: I held down the orange wifi button above the keyboard (this is on a Compaq) near the power switch and toggled the wifi switch in network settings. Wifi button turned blue and wifi options showed up in Network Settings. Not sure it will work for everyone, but worked for me!

BTW, this relates to the answer by Subham Patel.


Had the same problem and nothing helped. Then stumbled on a very simple solution that works for me everytime - just suspend the system. Once suspended, simply log back in again. The wifi should now be enabled.

Can't explain why this works - but it does.


All those facing Hard Blocked problem just press the wifi button on your keyboard! It will work!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.