1

I've already tried with 3 or 4 tutorials to install GIMP 2.8 or 2.9. But I always get the same error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gimp : Depends: libgimp2.0 (>= 2.9.5~65-0t4~ppa~00faf17) but it is not going to be installed
        Depends: libgimp2.0 (<= 2.9.5~65-z) but it is not going to be installed
        Depends: libgegl-0.3-0 (>= 1:0.3.6.20) but it is not going to be installed
        Depends: libmypaint (>= 1.3.0-0t2~ppa) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I use elementaryOS 3.0 Freya. Help

1

Actually, I don't know why you need tutorials - if you needed 4 tutorials and still couldn't install it then probably there's something really stinky.

Generally, the easiest way is to hit Function Key+T - you'll get the terminal- then write sudo apt install gimp. Now you'll be asked for your password (type it and remember that there are no display of typed letters, even dots). When you are asked to type y or n, hit y and enter. It should install gimp with all it's features.

If you get an error, please provide error message and what tutorials you've used/what have you installed. Maybe you installed some old packages that are not compatible.

  • The error mesage i get after running sudo apt-get install gimp is exact the same I posted in my question. :/ – Gabriel Pellegrino Jan 19 '17 at 12:51
  • Ok, so try running sudo apt-get -f install And again try installing gimp – Dysproz Jan 19 '17 at 21:17
  • If it doesn't work, try using sudo apt autoclean – Dysproz Jan 19 '17 at 21:18
  • None of these worked :s – Gabriel Pellegrino Jan 19 '17 at 21:41
  • Try sudo apt-get -u dist-upgrade and if you get info about held packages try: sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade – Dysproz Jan 20 '17 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.