5

I have a touchscreen Dell XPS 9550 and an external 27" Dell screen.

How can I make sure the external monitor doesn't scale everything up as it currently is by 2x?

The XPS is HiDPI whilst the screen is FHD. Output from xrandr -q reveals the following:

eDP1 connected primary 3840x2160+2560+0 (normal left inverted right x axis y axis) 350mm x 190mm ... HDMI1 connected 2560x1440+0+214 (normal left inverted right x axis y axis) 600mm x 340mm

I initially followed the instructions on https://askubuntu.com/questions/393400/is-it-possible-to-have-two-different-dpi-configurations-for-two-different-screen however Pantheon keeps resetting itself, and I'm unable to set the desired dimensions ( adjusted the calculations based upon the output above.

I'm trying to set the XPS to the right of the monitor.

2

This largely works for me:

xrandr --output eDP1 --scale 1x1 --pos 3840x0 ; xrandr --output HDMI1 --scale 2x2 --mode 1920x1080 --fb 7680x2160 --pos 0x0

Only downside is the topbar seems to get in the way on my laptop screen. Obviously you'll need to adjust if you don't have same resolution as I do. Afraid there is no GUI solution yet. I just popped this command into a file so I can quickly switch.

UPDATE Pantheon keeps crashing out on me now, when changing res!

UPDATE 2

Seems to be more successful when you plug in monitor after fully loading up and logging in.

  • Trying to run this on my setup (very similar to the one from Demwunz) and I am getting 'xrandr: cannot find mode 1920x1080' - my screen does have a res of 1920x1080 so not sure why that happens. Any ideas? – Markus Aug 3 '17 at 8:52
1

Unfortunately, the current Linux desktop supports only one scale factor for the entire desktop, so either you scale down your HiDPI monitor, or you get double size on your external.

I have a very similar setup and the simple work-around I use now is to set the laptop display to 1280 x 720 in System Settings > Displays.

For more info check out these blog posts:

https://medium.com/elementaryos/what-is-hidpi-and-why-does-it-matter-b024eabea20d
https://medium.com/elementaryos/top-3-misconceptions-about-hidpi-f5ef493d7bf8
0
xrandr --output eDP-1 --scale 1x1 --pos 0x0 --fb 7680x2160; xrandr --output DP-1-1 --scale 2x2 --pos 3840x0 --mode 1920x1080 --fb 7680x2160 --pos 3840x0

That did the trick for me.

Had to run "xrandr" only first to identify the names of the displays. eDP-1 was my laptop (4k Dell touch panel), and DP-1-1 was the HDMI output from my docking station.

Scale 1x1 in the laptop with 0x0 position and 7680x2160 of frame buffer, and then 2x2 scale on the 2nd display starting at 3840x0.

0

After several days of tinkering and trying several configurations, I would like to share the scripts (commands) that I've set in order to configure my desktops properly.

First of all, I have two screens: - Laptop Screen 3840x2160 (4k) - External Monitor through docking station 1920x1080 - Laptop panel will be "on the left" while the External monitor is on my right

xrandr --dpi 200 --fb 7680x2160 --output eDP-1 --mode 3840x2160 --output DP-1-1 --auto --scale 2x2 --pos 3840x0 --panning 3840x2160+3840+0

This gives me the PERFECT best experience and works seamlessly perfect (redundant, I know, but it's so preety...!)

I've turned this on a startu_script and just work flawlessly.

ProTip: if you need to adjust the gamma:

xrandr --output DP-1-1 --gamma 0.90:0.90:0.90 

I use 0.80 or 0.70 gamma all around depending time of day :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.