The wallpaper doesn't change when I set the wallpaper I have tried in System Settings or by the command line set-wallpaper

When I go to "Multitasking view" the new wallpaper does show but switches back to the old one when I am in normal view.

If I log out and log back in, it does update.

4 Answers 4


You have to restart or at least reload gala to change the wallpaper, for exemple you can type in a terminal window:

killall -HUP gala

This might be related to a bug as well…

  • Or open the Applications menu and type gala -r Apr 22, 2019 at 18:07

It looks like this is a known issue in Gala. The problem seems to be triggered by plugging in a new display.

The workaround posted by lemonslice resolves the problem for me.


I'm not sure what I changed, but this started working. I have been altering the NVIDIA settings, so that may have something to do with it.

Anyway, it's working as expected now without having to restart gala. I'll report again if I find what the bug was


If you have an Intel; run this in the terminal.

sudo apt-get purge xserver-xorg-video-intel
sudo apt autoremove

and reboot your system.

  • This uh... Yeah... I would not try this Do the video drivers magically reinstall themselves?
    – Eosdude
    Apr 27, 2017 at 22:06
  • You guys are talking crap to that poster, but His fix worked instantly for me. Be aware that I'm running ElementaryOS Juno, inside a VMware Workstation Pro 15 VM. However that fix worked across reboots as well. This is what worked: sudo apt-get purge xserver-xorg-video-intel; sudo apt autoremove
    – Will
    Nov 8, 2018 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.