0

and thanks for reading my question. (Before posting I checked many other questions on this forum, as well on other websites.) Recently I booted a live elementary OS Loki image on an old laptop to try the OS out and I decided to install it. Before installing, my display wasn't detected but the resolution was automatically set 1280*720, which is the ideal resolution for my screen. However, since I installed the OS the default resolution became 640*480 (4:3) and the display remains undetected. I cannot change it using the provided GUI (System Settings>Display), and I also tried to change it by using xrandr on the terminal but I found this quest to be fruitless.

I thought it could be a problem with my old laptop's graphics driver (Silicon Integrated Systems), since it appears it's support for linux has long been discontinued, and I also tried various methods for fixing this.

However, it still puzzles me how everything (resolution-wise) worked perfectly before the install. I even copied the kernel drives once from the live ISO image to my HDD in hopes the required drivers/the method through which the resolution was working would pass on to my installation...but that didn't work either (had to reinstall everything afterwards).

I was hoping there was a way to reproduce the same effects I have when I boot from the live USB to when I boot from the HDD, if more advanced things such as getting the OS to recognize my screen don't work.

If you know of a possible solution, please let me know. Thanks!

1

I finally find out how to correct this and I will leave it here for future reference for those who might be having similar issues. I just followed the answer posted here https://askubuntu.com/questions/455888/low-resolution-on-lubuntu-14-04-sis

"force the machine to use the vesa driver.

Create a file /usr/share/X11/xorg.conf.d/use-vesa.conf with the following content:

Section "Device"
  Identifier "Configured Video Device"
  Driver "vesa"
EndSection

And that's all. Reboot, and you should have your resolution."

0

please try ....

  • at the grub boot
  • add the option nomodeset
  • then boot
  • Hi George. Thanks for your suggestion. I tried to do what you told me as shown in this link askubuntu.com/questions/38780/… (user: fossfreedom) However when I booted everything looked the same and still wasn't able to change the resolution through the GUI. Perhaps I missed something? – user7350907 Jan 11 '17 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.