0

Good Morning everyone, how can i change the grub2 bootloader timeout? (direct command in terminal to change it to 0 sec) Also what are the other tips to make this boot faster?

1

Open with your favorite text editor /etc/default/grub in sudo mode.

You'll see: /etc/default.grub

GRUB_TIMEOUT=10 stands for grub timeout. Change it to your desired value and save. :)

If you want to change sth more in grub then you have it here too ;)

| improve this answer | |
1

Systems with LVM partition enabled experience no timeout changes when setting GRUB_TIMEOUT. The reason is that grub lacks write support for LVM. Further info you can find at here

Adding a timeout for recordFail at /etc/default/grub in Grub should solve your issue:

sudo sh -c 'echo GRUB_RECORDFAIL_TIMEOUT=0 >> /etc/default/grub'
sudo update-grub

It will add GRUB_RECORDFAIL_TIMEOUT=0 to /etc/default/grub file

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.