The only thing that's preventing me from using other workspaces (besides the main one) is that I can't switch between them properly.

  1. ALT+TAB will only switch between apps in the current workspace.
  2. Super+Left/Right will iterate through an empty workspace, which is annoying.

Can I change any of these options?

  • The first question has already an answer here: elementaryos.stackexchange.com/questions/7749/…
    – lemonslice
    Jan 5, 2017 at 16:26
  • What do you mean by iterating through an empty workspace? You can put applications there as well and it will no more be empty…
    – lemonslice
    Jan 5, 2017 at 16:28
  • So I guess the first option is off the table, thanks. Also, what I mean is that if I put applications there it'll create a third workspace which will be empty.
    – galah92
    Jan 5, 2017 at 17:06
  • You can disable dynamic workspaces under org.pantheon.desktop.gala.behavior, set dynamic_workspaces to false. Nevertheless, there is no "empty workspace" created unless you put something there.
    – lemonslice
    Jan 5, 2017 at 17:25
  • Great! it kinda did the job. How can I set this fixed number? It always creates 4 workspaces.
    – galah92
    Jan 5, 2017 at 17:40

2 Answers 2


You can disable dynamic workspaces:

gsettings set org.pantheon.desktop.gala.behavior dynamic-workspaces false

You can set the number of workspaces wanted to NUMBER:

gsettings set org.gnome.desktop.wm.preferences num-workspaces NUMBER

(Nevertheless, even if you use dynamic workspaces, there are actually no "empty workspaces"…).

  • Thank you so much! This answered my other question about how to get apps to stop opening in a new workspace. (elementaryos.stackexchange.com/questions/10645/…) Feb 10, 2017 at 21:51
  • 1
    The solution has changed. Use the following command instead: "gsettings set org.gnome.mutter dynamic-workspaces false". The command to set the number of workspaces continues to be the same as before. Jan 17, 2020 at 19:54

The title of your question was a bit contradictory (therefore I have edited it a bit), as there were multiple questions involved; you seem to prefer to disable the workspaces but also to give them a second chance if a better way to switch them was to be presented to you.

As you have selected a definitive answer, I imagine that the most important part was how to disable them.

But there is also the other question in the question body, as you say:

The only thing that's preventing me from using other workspaces (besides the main one) is that I can't switch between them properly.


Can I change any of these options?

What would it be for you the proper way to switch between the workspaces?

The range of possibilities is large: see here.

To simply cycle them, there is also + Tab.

To display them all and their windows I like + S. Only the windows of the selected workspace are displayed in this way (unlike + W which shows all windows, including conkys, which is not too clever; that shortcut can be edited - I changed it to + A myself).

The same can be achieved with a hot corner (e.g. 'Settings-Desktop-Hot corners', and setting down-left corner to Multitasking view.)

When the multitasking view is displayed, the mouse or touchpad scroll will switch the workspaces too.

The use of the hot-corner and the wheel/scroll allows to switch workspaces only with the mouse or touchpad.

That is very useful for me in selecting/closing windows especially when the dock is set to auto-hide.

I use workspaces mostly when I run an application that I don't need too often (e.g. a script in a terminal that I need to monitor only rarely), or when I need to cycle only the windows of the same application.

Any application gets its own separate workspace if set to fullscreen with Super-F.

You can edit a lot of shortcuts under 'Settings-Keyboard-Shortcuts-Workspaces'.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.