2

My Internet connection is painfully slow and irregular on elementary OS Loki.

I'm connected to the Internet via WiFi through a PCI antenna.

What I experience is that I get disconnected from time to time, also the indicator shows a weak signal, but I just restart the connection and it shows a strong one again.

Trying to download from the AppCenter or using apt-get install is horrible. Right now I'm downloading the openjdk-9-jre, is a 183 MB download that is taking from hours to days according to the Terminal. This same download on my Windows partition would take from 15 to 25 minutes top.

I tried to use Popcorn Time and the Internet connection kept slowing until reaching 0 kbps, then I would restart the connection, it would comeback up and then down again. Using Transmission for torrents gets me the same result.

Strangely, I can browse the web and watch stuff like YouTube normally.

None of this issues happen on my Windows 10 partition, and they didn't appear while using elementary OS Luna or Freya.

If you need any Terminal input, just let me know.

Thank you.

  • What's the output of "sudo lshw -C network"? – bitseater Jan 4 '17 at 21:40
  • @bitseater *-network description: Wireless interface product: RT3060 Wireless 802.11n 1T/1R vendor: Ralink corp. physical id: 5 bus info: pci@0000:04:05.0 logical name: wlp4s5 version: 00 serial: 00:27:11:01:ec:35 width: 32 bits clock: 33MH – Jbastardov Jan 4 '17 at 21:46
  • @bitseater capabilities: pm bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=rt2800pci driverversion=4.4.0-57-generic firmware=0.34 ip=192.168.1.104 latency=64 link=yes maxlatency=4 mingnt=2 multicast=yes wireless=IEEE 802.11bgn resources: irq:20 memory:febf0000-febfffff – Jbastardov Jan 4 '17 at 21:48
  • @bitseater *-network description: Ethernet interface product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller vendor: Realtek Semiconductor Co., Ltd. physical id: 0 bus info: pci@0000:03:00.0 logical name: enp3s0 version: 06 serial: c8:60:00:5a:dd:85 size: 10Mbit/s capacity: 1Gbit/s width: 64 bits clock: 33MHz – Jbastardov Jan 4 '17 at 21:48
  • @bitseater capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s resources: irq:33 ioport:e800(size=256) memory:fdfff000-fdffffff memory:fdff8000-fdffbfff – Jbastardov Jan 4 '17 at 21:49
1

There are some known issues between Broadcom and Ralink drivers. You can try to remove and purge the first with:

sudo apt-get purge bcmwl-kernel-source 

and reboot your system.

If you hate reboot :P , you can try:

sudo modprobe -r rt2800pci
sudo apt-get purge bcmwl-kernel-source
sudo modprobe rt2800pci
sudo service network-manager restart
  • Thank you for your help. In the end there seems to be an issue on how Loki (I'm guessing is a kernel problem) interacts with the driver of my old PCI Wi-Fi antena. I tried using an old USB antena and the Internet was working flawlessly. – Jbastardov Jan 26 '17 at 4:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.