I booted into live CD and I got the options where you can try elementary OS or install it, but every time I choose one of them it turns into a black screen and then after a few second my monitor can't detect a signal from my computer. This never happened to me on other distros just on this one. I have an AMD A6-7400k with r5 graphics and 4gb of ram

  • error No UMS support in radeon module i got this far
    – luka
    Commented Apr 17, 2017 at 2:03
  • Also same problem installing on a 2008 Macbook Pro - nomodeset solution worked for me too
    – simonn
    Commented Apr 18, 2019 at 20:20

2 Answers 2


Try launching your kernel with nomodeset option, following this instructions:

  • During the boot process, press and hold SHIFT key. Now you can see the grub menu.

  • Press e key on first line to edit it.

  • Go to line with the quiet splashsentence. Something like: linux /boot/vmlinuz-4.4.0-57-generic root=UUID=xxxx-xxxx-xxxxx ro quiet splash.

  • Add the nomodeset option between ro and quiet splash. You must see someting like: linux /boot/vmlinuz-4.4.0-57-generic root=UUID=xxxx-xxxx-xxxxx ro nomedeset quiet splash.

  • Press Ctrl + X to boot the kernel.

Report your experience to help others.

  • 1
    I had same problem.. I tried what @bitseater says with nomodeset. I successfully booted to livecd and install Elementary OS :)
    – johhhnnyy
    Commented Feb 15, 2017 at 17:21
  • I don't see a uuid for the root= it says maybe casper . When I set nomodeset, it shuts off and restarts. Commented Mar 4, 2020 at 10:53
  • A few years later, same problem. My screen was cycling between solid colors when trying to boot into Ubuntu (or Mint) from a live USB stick. The 'quite splash' line didn't have anything similar to the text in this answer. Still, I added ´nomodeset´ just before ´quite splash´, and it worked. Thanks!
    – pilgix
    Commented Feb 15, 2023 at 23:35

Running Odin [Built on Ubuntu 20.04.3 LTS] in demo mode on an ssd attached by usb-c on a macbook pro: 1× Intel® Core™ i5-6267U CPU @ 2.90GHz

nomodeset did not work for me, but acpi=off works. I saw it in an ubuntu thread. but it notes that this may disable certain critical functions like the fan. Any info on acpi=off appreciated.

Also worth noting: track pad and keyboard do not work, but mouse and keyboard connected by usb do work.

Outside temperature is 95F at hottest spots.. do not hear fan. Will keep checking temp. Otherwise, no issue noted and laser razor fast.

Using a usb dongle that connects by wifi to my left handed orbital trackball with scroll wheel.. and amazingly all of it works perfectly.

Not the answer you're looking for? Browse other questions tagged or ask your own question.