2 added 199 characters in body
source | link

Elementary has been running very well on my Dell XPS 13 9343 for months, but today I decided to try to scale up the display a bit because it was a little hard to read text. I entered the following command:

gsettings set org.gnome.desktop.interface scaling-factor 21

Instead of 2.1 (also, scaling with floats didn't work, only integers like 1, 2, 3, etc).

The problem is that now, logging in crashes Pantheon before I can launch a terminal window, let alone enter the commands to reset scaling to 2, and kicks me back to the login screen. Cntl-alt-F1/F2/etc. does not bring up a shell like it does in Ubuntu, which would allow me to edit it without launching Pantheon. Also, going into recovery and getting a root shell won't allow me to change the setting because the system files are read-only in recovery.

Am I missing some easy way to bring up a shell from the login screen? How can I repair this? Also, is it possible to scale the display by %? 2 is too small and 3 is too large.

Thanks

Edit to clarify: Pantheon launches with the huge menu bar across the top. Super+Space opens the app launcher, then the session crashes. If I don't do anything, the display shows only the wallpaper (properly scaled) and then the whole computer freezes, requiring a hard shutdown.

Update: I can pull up TTY1 with Ctl-Fn-Alt-F1, but setting gsettings from there brings up the error: dconf-WARNING: failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY

Elementary has been running very well on my Dell XPS 13 9343 for months, but today I decided to try to scale up the display a bit because it was a little hard to read text. I entered the following command:

gsettings set org.gnome.desktop.interface scaling-factor 21

Instead of 2.1 (also, scaling with floats didn't work, only integers like 1, 2, 3, etc).

The problem is that now, logging in crashes Pantheon before I can launch a terminal window, let alone enter the commands to reset scaling to 2, and kicks me back to the login screen. Cntl-alt-F1/F2/etc. does not bring up a shell like it does in Ubuntu, which would allow me to edit it without launching Pantheon. Also, going into recovery and getting a root shell won't allow me to change the setting because the system files are read-only in recovery.

Am I missing some easy way to bring up a shell from the login screen? How can I repair this? Also, is it possible to scale the display by %? 2 is too small and 3 is too large.

Thanks

Edit to clarify: Pantheon launches with the huge menu bar across the top. Super+Space opens the app launcher, then the session crashes. If I don't do anything, the display shows only the wallpaper (properly scaled) and then the whole computer freezes, requiring a hard shutdown.

Elementary has been running very well on my Dell XPS 13 9343 for months, but today I decided to try to scale up the display a bit because it was a little hard to read text. I entered the following command:

gsettings set org.gnome.desktop.interface scaling-factor 21

Instead of 2.1 (also, scaling with floats didn't work, only integers like 1, 2, 3, etc).

The problem is that now, logging in crashes Pantheon before I can launch a terminal window, let alone enter the commands to reset scaling to 2, and kicks me back to the login screen. Cntl-alt-F1/F2/etc. does not bring up a shell like it does in Ubuntu, which would allow me to edit it without launching Pantheon. Also, going into recovery and getting a root shell won't allow me to change the setting because the system files are read-only in recovery.

Am I missing some easy way to bring up a shell from the login screen? How can I repair this? Also, is it possible to scale the display by %? 2 is too small and 3 is too large.

Thanks

Edit to clarify: Pantheon launches with the huge menu bar across the top. Super+Space opens the app launcher, then the session crashes. If I don't do anything, the display shows only the wallpaper (properly scaled) and then the whole computer freezes, requiring a hard shutdown.

Update: I can pull up TTY1 with Ctl-Fn-Alt-F1, but setting gsettings from there brings up the error: dconf-WARNING: failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY

1
source | link

Display Scaling Crashes Pantheon, No Way to Fix

Elementary has been running very well on my Dell XPS 13 9343 for months, but today I decided to try to scale up the display a bit because it was a little hard to read text. I entered the following command:

gsettings set org.gnome.desktop.interface scaling-factor 21

Instead of 2.1 (also, scaling with floats didn't work, only integers like 1, 2, 3, etc).

The problem is that now, logging in crashes Pantheon before I can launch a terminal window, let alone enter the commands to reset scaling to 2, and kicks me back to the login screen. Cntl-alt-F1/F2/etc. does not bring up a shell like it does in Ubuntu, which would allow me to edit it without launching Pantheon. Also, going into recovery and getting a root shell won't allow me to change the setting because the system files are read-only in recovery.

Am I missing some easy way to bring up a shell from the login screen? How can I repair this? Also, is it possible to scale the display by %? 2 is too small and 3 is too large.

Thanks

Edit to clarify: Pantheon launches with the huge menu bar across the top. Super+Space opens the app launcher, then the session crashes. If I don't do anything, the display shows only the wallpaper (properly scaled) and then the whole computer freezes, requiring a hard shutdown.