10 replaced http://askubuntu.com/ with https://askubuntu.com/
source | link

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "


My favorite solution is:

sudo apt install language-selector-gnome

From Applications/Slingshot launch 'Language Support' (gnome-language-selector - part of language-selector-gnome).

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.


This problem seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may seem related to a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.) - Possibly this is not a qt issue.


There seems to be a temporary fix indicated in the answer under the askubuntu linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(Adding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "


My favorite solution is:

sudo apt install language-selector-gnome

From Applications/Slingshot launch 'Language Support' (gnome-language-selector - part of language-selector-gnome).

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.


This problem seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may seem related to a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.) - Possibly this is not a qt issue.


There seems to be a temporary fix indicated in the answer under the askubuntu linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(Adding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "


My favorite solution is:

sudo apt install language-selector-gnome

From Applications/Slingshot launch 'Language Support' (gnome-language-selector - part of language-selector-gnome).

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.


This problem seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may seem related to a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.) - Possibly this is not a qt issue.


There seems to be a temporary fix indicated in the answer under the askubuntu linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(Adding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).

9 added 65 characters in body
source | link

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "

 

ItMy favorite solution is:

sudo apt install language-selector-gnome

From Applications/Slingshot launch 'Language Support' (gnome-language-selector - part of language-selector-gnome).

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.


This problem seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may beseem related to a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.) - Possibly this is not a qt issue.


There seems to be a temporary fix indicated in the answer under the askubuntu linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(Adding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).


I have also found a different solution:

sudo apt install language-selector-gnome

Launch 'Language Support' from Applications/Slingshot.

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "

It seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may be a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.)


There seems to be a temporary fix indicated in the answer under the linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(Adding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).


I have also found a different solution:

sudo apt install language-selector-gnome

Launch 'Language Support' from Applications/Slingshot.

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "

 

My favorite solution is:

sudo apt install language-selector-gnome

From Applications/Slingshot launch 'Language Support' (gnome-language-selector - part of language-selector-gnome).

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.


This problem seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may seem related to a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.) - Possibly this is not a qt issue.


There seems to be a temporary fix indicated in the answer under the askubuntu linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(Adding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).

8 added 306 characters in body
source | link

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "

It seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may be a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.)


There seems to be a temporary fix indicated in the answer under the linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(I don know why, but addingAdding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).


I have also found a different solution:

sudo apt install language-selector-gnome

Launch 'Language Support' from Applications/Slingshot.

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "

It seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may be a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.)


There seems to be a temporary fix indicated in the answer under the linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(I don know why, but adding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "

It seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may be a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.)


There seems to be a temporary fix indicated in the answer under the linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(Adding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).


I have also found a different solution:

sudo apt install language-selector-gnome

Launch 'Language Support' from Applications/Slingshot.

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.

7 added 170 characters in body
source | link
6 added 178 characters in body
source | link
5 added 4 characters in body
source | link
4 added 73 characters in body
source | link
3 added 33 characters in body
source | link
2 added 316 characters in body
source | link
1
source | link